Home > Guardian Error Handling System > Help > 1010

Dealing with error "The crypt() function is unimplemented due to excessive paranoia"

When running the Guardian admin script, you may encounter this error:

	The crypt() function is unimplemented due to excessive paranoia.
	at ./ag-shared.txt line 888.

(The exact line number and message text may vary.)

In order to log in to the admin page, your version of Perl must support the crypt function. Some older versions of Windows Perl did not support this function under the mistaken belief that supporting it would violate cryptography export laws. All new versions of Windows Perl from ActiveState do support the function.

If your web server does not have a current version of Perl installed, and you cannot get the powers-that-be to upgrade, then you can still use this script but you cannot use the admin control panel. You will have to configure the "system.txt" and "filters.txt" files manually.

See: System requirements


    "Dealing with error "The crypt() function is unimplemented due to excessive paranoia""
    http://www.xav.com/scripts/guardian/help/1010.html